Breakage in Leopard – RMagick fails to find libdpstk.1.dylib

Some small breakage in Leopard – it seems a couple of parts of X11 have been removed. Starting my rails setup, which has GraphicsMagick installed (read here for how), results in this:

dyld: NSLinkModule() errordyld: Library not loaded: /usr/X11R6/lib/libdpstk.1.dylib  Referenced from: /usr/local/lib/ruby/gems/1.8/gems/rmagick-1.15.9/lib/RMagick.bundle  Reason: image not foundTrace/BPT trap

Those dylib files do not exist any more. But… I have a backup (I hope you do). I ended up doing this:

$ cd /Volumes/BackupDisk/usr/X11R6/lib$ sudo cp libdps*1.0* /usr/X11R6/lib/$ sudo ln -s /usr/X11R6/lib/libdpstk.1.0.dylib /usr/X11R6/lib/libdpstk.1.dylib$ sudo ln -s /usr/X11R6/lib/libdps.1.0.dylib /usr/X11R6/lib/libdps.1.dylib

All fixed.Without a backup you are going to need to find those two files from somewhere. I’m not sure I can legally post them here, but email me if you are stuck.

Advertisements

6 thoughts on “Breakage in Leopard – RMagick fails to find libdpstk.1.dylib

  1. Hi,I am stuck! By backup, do you mean to an earlier version of OSX? If so, I don’t think I have them. Could you e-mail them or suggest another way for me to do it?libdpstk.1.dylib is what I am looking for.Thanks very much!

  2. Did you try reinstalling GraphicsMagick? I don’t know that, but I know that if you update ImageMagick undernearth rmagick you’ll need to reinstall rmagick. It has a binary component which needs to be re-linked.Just a suggestion, hope it helps save others some time.

  3. >>> "can’t map"I have the same error when running SMTP from python.Tried what you said above (I found the lib files in /Developer/SDKs, and copied and linked them)However, *now* it says:dyld: Library not loaded: /usr/X11R6/lib/libdpstk.1.dylib Referenced from: /sw/bin/import Reason: no suitable image found. Did find:
    /usr/X11R6/lib/libdpstk.1.dylib: can’t map./smtpclient.py: line 1: 25488 Trace/BPT trap import smtplib

  4. Hi: I am also stuck… I tried looking through my installation disks (10.5.5) And could not find the libraries required, tried installing X11, X11SDK, devSDK, and several other packages and I still get the same messagedyld: Library not loaded: /usr/X11R6/lib/libdpstk.1.dylibcould you email me the libraries or suggest where to get them from?Thanks

  5. […] for missing X11 libraries in Leopard This solution comes straight from??Penny Smalls.??I’ve just put it here for personal […]

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s